1C: Управление строительной организацией

Форум пользователей и партнеров
Текущее время: Пн окт 22, 2018 6:07 am

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ 1 сообщение ] 
Автор Сообщение
 Заголовок сообщения: счет-фактура полученный
СообщениеДобавлено: Чт янв 26, 2012 10:29 am 
Не в сети

Зарегистрирован: Пн окт 01, 2007 3:37 pm
Сообщения: 1068
Для печати счета-фактуры полученного в документах строительного бух. учета необходимо выполнить следующие рекомендации (для тех, кто не имеет возможности внести исправления - поправки будут учтены в 22 релизе. Релиз готовится к выпуску).

Открыть конфигурацию. Найти в дереве документов "СчетФактураПолученный". Нажать правой кнопкой на нём - из появившегося контекстногоменю выбрать "Модуль менеджера".
1) В самый конец текста модуля вставить слеудующий текст
Функция СобратьДанныеПоАктуОбУслугахЗаказчика(ДокОснование, Ссылка)
//-- 01.08.2007 ЭРТИ БАЮ
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ДокументОснование", ДокОснование);
Запрос.Текст =
"ВЫБРАТЬ
| Организация,
| Организация КАК Покупатель,
| Организация КАК Грузополучатель,
| Контрагент КАК Поставщик,
| Контрагент КАК Грузоотправитель,
| СуммаДокумента КАК Сумма,
| ВалютаДокумента КАК Валюта,
| УчитыватьНДС КАК УчитыватьНДС,
| СуммаВключаетНДС КАК СуммаВключаетНДС
|ИЗ
| Документ.АктОбУслугахЗаказчика КАК АктОбУслугахЗаказчика
|
|ГДЕ
| АктОбУслугахЗаказчика.Ссылка = &ДокументОснование";

ЗапросПоТоварам = Новый Запрос();
ЗапросПоТоварам.УстановитьПараметр("Курс", ДокОснование.КурсВзаиморасчетов);
ЗапросПоТоварам.УстановитьПараметр("Кратность", ДокОснование.КратностьВзаиморасчетов);
ЗапросПоТоварам.УстановитьПараметр("ТекущийДокумент", ДокОснование.Ссылка);
ЗапросПоТоварам.Текст = "
// |ВЫБРАТЬ
// | ВложенныйЗапрос.НомерСтроки,
// | ВложенныйЗапрос.Товар,
// | ВложенныйЗапрос.Товар.НаименованиеПолное КАК ТоварНаименование,
// | ВложенныйЗапрос.Характеристика,
// | ВложенныйЗапрос.Серия,
// | ВложенныйЗапрос.СтранаПроисхождения,
// | ВложенныйЗапрос.СтранаПроисхождения.НаименованиеПолное КАК ПредставлениеСтраны,
// | ВложенныйЗапрос.НомерГТД,
// | ВложенныйЗапрос.НомерГТД.Представление КАК ПредставлениеГТД,
// | ВложенныйЗапрос.ЕдиницаИзмерения.Представление КАК ЕдиницаИзмерения,
// | ВложенныйЗапрос.Количество,
// | ВложенныйЗапрос.Цена,
// | ВложенныйЗапрос.Сумма,
// | ВложенныйЗапрос.СуммаНДС,
// | ВложенныйЗапрос.СтавкаНДС
// |ИЗ
// | (ВЫБРАТЬ
// | ТаблицаПоТоварам.НомерСтроки КАК НомерСтроки,
// | ТаблицаПоТоварам.Номенклатура КАК Товар,
// | ТаблицаПоТоварам.ХарактеристикаНоменклатуры КАК Характеристика,
// | ТаблицаПоТоварам.СерияНоменклатуры КАК Серия,
// | ТаблицаПоТоварам.СерияНоменклатуры.СтранаПроисхождения КАК СтранаПроисхождения,
// | ТаблицаПоТоварам.СерияНоменклатуры.НомерГТД КАК НомерГТД,
// | ТаблицаПоТоварам.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
// | СУММА(ТаблицаПоТоварам.Количество) КАК Количество,
// | ТаблицаПоТоварам.Цена КАК Цена,
// | ТаблицаПоТоварам.Сумма КАК Сумма,
// | ТаблицаПоТоварам.СуммаНДС КАК СуммаНДС,
// | ТаблицаПоТоварам.СтавкаНДС КАК СтавкаНДС
// | ИЗ
// | Документ.АктОбУслугахЗаказчика.Товары КАК ТаблицаПоТоварам
// |
// | ГДЕ
// | ТаблицаПоТоварам.Ссылка = &ТекущийДокумент
// |
// | СГРУППИРОВАТЬ ПО
// | ТаблицаПоТоварам.НомерСтроки,
// | ТаблицаПоТоварам.Номенклатура,
// | ТаблицаПоТоварам.ХарактеристикаНоменклатуры,
// | ТаблицаПоТоварам.СерияНоменклатуры,
// | ТаблицаПоТоварам.ЕдиницаИзмерения,
// | ТаблицаПоТоварам.СтавкаНДС,
// | ТаблицаПоТоварам.Цена,
// | ТаблицаПоТоварам.СерияНоменклатуры.СтранаПроисхождения,
// | ТаблицаПоТоварам.СерияНоменклатуры.НомерГТД,
// | ТаблицаПоТоварам.Сумма,
// | ТаблицаПоТоварам.СуммаНДС) КАК ВложенныйЗапрос

//// |ОБЪЕДИНИТЬ ВСЕ

|ВЫБРАТЬ
| ТаблицаПоУслугам.НомерСтроки КАК НомерСтроки,
| ТаблицаПоУслугам.Номенклатура КАК Товар,
| ТаблицаПоУслугам.Номенклатура.НаименованиеПолное КАК ТоварНаименованиеПолное,
| ТаблицаПоУслугам.Содержание КАК ТоварНаименование,
| """" КАК Характеристика,
| """" КАК Серия,
| ""Россия"" КАК СтранаПроисхождения,
| ""Россия"" КАК ПредставлениеСтраны,
| ""--"" КАК НомерГТД,
| ""--"" КАК ПредставлениеГТД,
| ТаблицаПоУслугам.Номенклатура.ЕдиницаХраненияОстатков.Представление КАК ЕдиницаИзмерения,
| ТаблицаПоУслугам.Количество,
| ТаблицаПоУслугам.Цена,
| ТаблицаПоУслугам.Сумма,
| ТаблицаПоУслугам.СуммаНДС,
| ТаблицаПоУслугам.СтавкаНДС
|ИЗ
| Документ.АктОбУслугахЗаказчика.Услуги КАК ТаблицаПоУслугам

|ГДЕ
| ТаблицаПоУслугам.Ссылка = &ТекущийДокумент";

//--------------- 07.08.2008 ЭРТИ ГЕР
Если ДокОснование.ВидОперации = Перечисления.ВидыОперацийУслугиЗаказчика.Услуги Тогда
ЗапросПоТоварам.Текст = "
|ВЫБРАТЬ
| ТаблицаПоУслугам.НомерСтроки КАК НомерСтроки,
| ТаблицаПоУслугам.Номенклатура КАК Товар,
| ТаблицаПоУслугам.Номенклатура.НаименованиеПолное КАК ТоварНаименованиеПолное,
| ТаблицаПоУслугам.Содержание КАК ТоварНаименование,
| """" КАК Характеристика,
| """" КАК Серия,
| ""Россия"" КАК СтранаПроисхождения,
| ""Россия"" КАК ПредставлениеСтраны,
| ""--"" КАК НомерГТД,
| ""--"" КАК ПредставлениеГТД,
| ТаблицаПоУслугам.Номенклатура.ЕдиницаХраненияОстатков.Представление КАК ЕдиницаИзмерения,
| ТаблицаПоУслугам.Количество,
| ТаблицаПоУслугам.Цена,
| ТаблицаПоУслугам.Сумма,
| ТаблицаПоУслугам.СуммаНДС,
| ТаблицаПоУслугам.СтавкаНДС
|ИЗ
| Документ.АктОбУслугахЗаказчика.Услуги_ КАК ТаблицаПоУслугам

|ГДЕ
| ТаблицаПоУслугам.Ссылка = &ТекущийДокумент";

КонецЕсли;
//---------------

Шапка = Запрос.Выполнить().Выбрать();
ВыборкаСтрокТовары = ЗапросПоТоварам.Выполнить().Выбрать();

Шапка.Следующий();
ДанныеДляПечати = Новый Структура();
ДанныеДляПечати.Вставить("Организация", Шапка.Организация);
ДанныеДляПечати.Вставить("Номер", Ссылка.НомерВходящегоДокумента);
ДанныеДляПечати.Вставить("Дата", Ссылка.ДатаВходящегоДокумента);
ДанныеДляПечати.Вставить("Поставщик", Шапка.Поставщик);
ДанныеДляПечати.Вставить("Грузоотправитель", Шапка.Грузоотправитель);
ДанныеДляПечати.Вставить("Покупатель", Шапка.Покупатель);
ДанныеДляПечати.Вставить("Грузополучатель", Шапка.Грузополучатель);
ДанныеДляПечати.Вставить("Сумма", Шапка.Сумма);
ДанныеДляПечати.Вставить("Валюта", Шапка.Валюта);
ДанныеДляПечати.Вставить("УчитыватьНДС", Шапка.УчитыватьНДС);
ДанныеДляПечати.Вставить("ФИОРуководителя", );
ДанныеДляПечати.Вставить("ФИОГлавногоБухгалтера", );

Товары = ИнициализацияТаблицыСтрок();

Пока ВыборкаСтрокТовары.Следующий() = 1 Цикл

Строчка = Товары.Добавить();

Если ЗначениеЗаполнено(ВыборкаСтрокТовары.Товар) Тогда
Строчка.Товар = ВыборкаСтрокТовары.Товар;
Строчка.ТоварНаименование = ВыборкаСтрокТовары.ТоварНаименованиеПолное+" "+СокрЛП(ВыборкаСтрокТовары.ТоварНаименование);
КонецЕсли;

Строчка.СтранаПроисхождения = ВыборкаСтрокТовары.СтранаПроисхождения;
Строчка.ПредставлениеСтраны = ?(НЕ ЗначениеЗаполнено(ВыборкаСтрокТовары.ПредставлениеСтраны), ВыборкаСтрокТовары.СтранаПроисхождения, ВыборкаСтрокТовары.ПредставлениеСтраны);
Строчка.НомерГТД = ВыборкаСтрокТовары.НомерГТД;
Строчка.ПредставлениеГТД = ВыборкаСтрокТовары.ПредставлениеГТД;
Строчка.Количество = ВыборкаСтрокТовары.Количество;
Строчка.ЕдиницаИзмерения = ВыборкаСтрокТовары.ЕдиницаИзмерения;
Строчка.СуммаВключаетНДС = Шапка.СуммаВключаетНДС;
Строчка.Цена = ВыборкаСтрокТовары.Цена;
Строчка.СтавкаНДС = ВыборкаСтрокТовары.СтавкаНДС;
Строчка.СуммаНДС = ВыборкаСтрокТовары.СуммаНДС;
Строчка.Сумма = ВыборкаСтрокТовары.Сумма;

КонецЦикла;

ДанныеДляПечати.Вставить("ТабличнаяЧасть", Товары);

Возврат ДанныеДляПечати;
//--
КонецФункции // СобратьДанныеПоАктуОбУслугахЗаказчика()

//--Эрти В.К
// Функция собирает данные по документу основанию СправкаОСубподрядныхРаботах и
// возвращает типизированную структуру с данными
//
Функция СобратьДанныеПоступлениеДенежныхДокументов(ДокОснование, Ссылка)
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ДокументОснование", ДокОснование);

//--------------- 27.07.2007 ЭРТИ ГЕР
Запрос.Текст =
"ВЫБРАТЬ
| ПоступлениеДенежныхДокументов.Организация,
| ВЫБОР
| КОГДА ПоступлениеДенежныхДокументов.Организация.ГоловнаяОрганизация.Ссылка ЕСТЬ NULL
| ТОГДА ПоступлениеДенежныхДокументов.Организация
| ИНАЧЕ ПоступлениеДенежныхДокументов.Организация.ГоловнаяОрганизация
| КОНЕЦ КАК Покупатель,
| ПоступлениеДенежныхДокументов.Организация КАК Грузополучатель,
| ПоступлениеДенежныхДокументов.Подразделение КАК Подразделение,
| ПоступлениеДенежныхДокументов.Контрагент КАК Поставщик,
| ПоступлениеДенежныхДокументов.Контрагент КАК Грузоотправитель,
| ПоступлениеДенежныхДокументов.СуммаДокумента КАК Сумма,
| ПоступлениеДенежныхДокументов.ВалютаДокумента КАК Валюта,
| ПоступлениеДенежныхДокументов.СуммаВключаетНДС,
| ПоступлениеДенежныхДокументов.УчитыватьНДС,
| ПоступлениеДенежныхДокументов.РасшифровкаПлатежа.(
| Ссылка,
| НомерСтроки,
| Номенклатура КАК Номенклатура,
| Сумма,
| СтавкаНДС,
| СуммаНДС,
| Ссылка.СуммаВключаетНДС КАК СуммаВключаетНДС,
| Номенклатура.Наименование + "" - ""+Серия.Код КАК ТоварНаименование,
| Количество,
| Цена,
| Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения
| )
|ИЗ
| Документ.ПоступлениеДенежныхДокументов КАК ПоступлениеДенежныхДокументов
|ГДЕ
| ПоступлениеДенежныхДокументов.Ссылка = &ДокументОснование";
//---------------
Шапка = Запрос.Выполнить().Выбрать();
Шапка.Следующий();
ВыборкаСтрокТовары = Шапка.РасшифровкаПлатежа.Выбрать();

ДанныеДляПечати = Новый Структура();
ДанныеДляПечати.Вставить("Организация", Шапка.Организация);
ДанныеДляПечати.Вставить("Номер", Ссылка.НомерВходящегоДокумента);
ДанныеДляПечати.Вставить("Дата", Ссылка.ДатаВходящегоДокумента);
ДанныеДляПечати.Вставить("Поставщик", Шапка.Поставщик);
ДанныеДляПечати.Вставить("Грузоотправитель", Шапка.Грузоотправитель);
ДанныеДляПечати.Вставить("Подразделение", Шапка.Подразделение);
ДанныеДляПечати.Вставить("Покупатель", Шапка.Покупатель);
ДанныеДляПечати.Вставить("Грузополучатель", Шапка.Грузополучатель);
ДанныеДляПечати.Вставить("Сумма", Шапка.Сумма);
ДанныеДляПечати.Вставить("Валюта", Шапка.Валюта);
ДанныеДляПечати.Вставить("УчитыватьНДС", Шапка.УчитыватьНДС);
ДанныеДляПечати.Вставить("СуммаВключаетНДС", Шапка.СуммаВключаетНДС);
ДанныеДляПечати.Вставить("ФИОРуководителя", );
ДанныеДляПечати.Вставить("ФИОГлавногоБухгалтера", );


Руководители = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизаций(Шапка.Поставщик, Ссылка.Дата);
ДанныеДляПечати.Вставить("ФИОРуководителя", Руководители.Руководитель);
ДанныеДляПечати.Вставить("ФИОГлавногоБухгалтера", Руководители.ГлавныйБухгалтер);

Товары = ИнициализацияТаблицыСтрок();

Пока ВыборкаСтрокТовары.Следующий() = 1 Цикл
Строчка = Товары.Добавить();
Строчка.Товар = ВыборкаСтрокТовары.Номенклатура;
Строчка.ТоварНаименование = СокрЛП(ВыборкаСтрокТовары.ТоварНаименование);
Строчка.СтранаПроисхождения = "";
Строчка.ПредставлениеСтраны = "";
Строчка.НомерГТД = "";
Строчка.ПредставлениеГТД = "";

Строчка.Количество = ВыборкаСтрокТовары.Количество;
Строчка.ЕдиницаИзмерения = ВыборкаСтрокТовары.ЕдиницаИзмерения;
Строчка.Цена = ВыборкаСтрокТовары.Цена;

Строчка.СтавкаНДС = ВыборкаСтрокТовары.СтавкаНДС;
Строчка.СуммаНДС = ВыборкаСтрокТовары.СуммаНДС;
Строчка.Сумма = ВыборкаСтрокТовары.Сумма;
Строчка.СуммаВключаетНДС = ВыборкаСтрокТовары.СуммаВключаетНДС;
КонецЦикла;

ДанныеДляПечати.Вставить("ТабличнаяЧасть", Товары);

Возврат ДанныеДляПечати;

КонецФункции

// Функция собирает данные по документу основанию СправкаОСубподрядныхРаботах и
// возвращает типизированную структуру с данными
//
Функция СобратьДанныеСправкамОСубподрядныхРаботах(ДокОснование, Ссылка)
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ДокументОснование", ДокОснование);

//--------------- 27.07.2007 ЭРТИ ГЕР
Запрос.Текст =
"ВЫБРАТЬ
| СправкаОСубподрядныхРаботах.Организация,
| ВЫБОР
| КОГДА СправкаОСубподрядныхРаботах.Организация.ГоловнаяОрганизация.Ссылка ЕСТЬ NULL
| ТОГДА СправкаОСубподрядныхРаботах.Организация
| ИНАЧЕ СправкаОСубподрядныхРаботах.Организация.ГоловнаяОрганизация
| КОНЕЦ КАК Покупатель,
| СправкаОСубподрядныхРаботах.Организация КАК Грузополучатель,
| СправкаОСубподрядныхРаботах.Подразделение КАК Подразделение,
| СправкаОСубподрядныхРаботах.Контрагент КАК Поставщик,
| СправкаОСубподрядныхРаботах.Контрагент КАК Грузоотправитель,
| СправкаОСубподрядныхРаботах.СуммаДокумента КАК Сумма,
| СправкаОСубподрядныхРаботах.ВалютаДокумента КАК Валюта,
| СправкаОСубподрядныхРаботах.СуммаВключаетНДС,
| СправкаОСубподрядныхРаботах.УчитыватьНДС,
| СправкаОСубподрядныхРаботах.Услуги.(
| Ссылка,
| НомерСтроки,
| Номенклатура КАК ОбъектСтроительства,
| Сумма,
| СтавкаНДС,
| СуммаНДС,
| Ссылка.СуммаВключаетНДС КАК СуммаВключаетНДС,
| Содержание КАК ОбъектСтроительстваНаименование,
| Количество,
| Цена,
| Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения
| )
|ИЗ
| Документ.СправкаОСубподрядныхРаботах КАК СправкаОСубподрядныхРаботах
|ГДЕ
| СправкаОСубподрядныхРаботах.Ссылка = &ДокументОснование";
//---------------
Шапка = Запрос.Выполнить().Выбрать();
Шапка.Следующий();
ВыборкаСтрокТовары = Шапка.Услуги.Выбрать();

ДанныеДляПечати = Новый Структура();
ДанныеДляПечати.Вставить("Организация", Шапка.Организация);
ДанныеДляПечати.Вставить("Номер", Ссылка.НомерВходящегоДокумента);
ДанныеДляПечати.Вставить("Дата", Ссылка.ДатаВходящегоДокумента);
ДанныеДляПечати.Вставить("Поставщик", Шапка.Поставщик);
ДанныеДляПечати.Вставить("Грузоотправитель", Шапка.Грузоотправитель);
ДанныеДляПечати.Вставить("Подразделение", Шапка.Подразделение);
ДанныеДляПечати.Вставить("Покупатель", Шапка.Покупатель);
ДанныеДляПечати.Вставить("Грузополучатель", Шапка.Грузополучатель);
ДанныеДляПечати.Вставить("Сумма", Шапка.Сумма);
ДанныеДляПечати.Вставить("Валюта", Шапка.Валюта);
ДанныеДляПечати.Вставить("УчитыватьНДС", Шапка.УчитыватьНДС);
ДанныеДляПечати.Вставить("СуммаВключаетНДС", Шапка.СуммаВключаетНДС);
ДанныеДляПечати.Вставить("ФИОРуководителя", );
ДанныеДляПечати.Вставить("ФИОГлавногоБухгалтера", );


Руководители = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизаций(Шапка.Поставщик, Ссылка.Дата);
ДанныеДляПечати.Вставить("ФИОРуководителя", Руководители.Руководитель);
ДанныеДляПечати.Вставить("ФИОГлавногоБухгалтера", Руководители.ГлавныйБухгалтер);

Товары = ИнициализацияТаблицыСтрок();

Пока ВыборкаСтрокТовары.Следующий() = 1 Цикл
Строчка = Товары.Добавить();
Строчка.Товар = ВыборкаСтрокТовары.ОбъектСтроительства;
Строчка.ТоварНаименование = СокрЛП(ВыборкаСтрокТовары.ОбъектСтроительстваНаименование);
Строчка.СтранаПроисхождения = "";
Строчка.ПредставлениеСтраны = "";
Строчка.НомерГТД = "";
Строчка.ПредставлениеГТД = "";
//--------------- 27.07.2007 ЭРТИ ГЕР
//Строчка.Количество = 0;
//Строчка.ЕдиницаИзмерения = "";
//Строчка.Цена = "";

Строчка.Количество = ВыборкаСтрокТовары.Количество;
Строчка.ЕдиницаИзмерения = ВыборкаСтрокТовары.ЕдиницаИзмерения;
Строчка.Цена = ВыборкаСтрокТовары.Цена;
//---------------
Строчка.СтавкаНДС = ВыборкаСтрокТовары.СтавкаНДС;
Строчка.СуммаНДС = ВыборкаСтрокТовары.СуммаНДС;
Строчка.Сумма = ВыборкаСтрокТовары.Сумма;
Строчка.СуммаВключаетНДС = ВыборкаСтрокТовары.СуммаВключаетНДС;
КонецЦикла;

ДанныеДляПечати.Вставить("ТабличнаяЧасть", Товары);

Возврат ДанныеДляПечати;

КонецФункции

// Функция собирает данные по документу основанию СправкаОбУслугахГенподрядчика и
// возвращает типизированную структуру с данными
//
Функция СобратьДанныеПоКорректировкамНеотфактурованнойПоставки(ДокОснование, Ссылка)

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ДокументОснование", ДокОснование);

Запрос.Текст =
"ВЫБРАТЬ
| Организация,
| Организация КАК Покупатель,
| Организация КАК Грузополучатель,
| Подразделение,
| Контрагент КАК Поставщик,
| Контрагент КАК Грузоотправитель,
| СуммаДокумента КАК Сумма,
| ВалютаДокумента КАК Валюта,
| УчитыватьНДС КАК УчитыватьНДС,
| СуммаВключаетНДС КАК СуммаВключаетНДС
|ИЗ
| Документ.КорректировкаНеотфактурованнойПоставки КАК КорректировкаНеотфактурованнойПоставки
|
|ГДЕ
| КорректировкаНеотфактурованнойПоставки.Ссылка = &ДокументОснование";

ЗапросПоТоварам = Новый Запрос();
ЗапросПоТоварам.УстановитьПараметр("Курс", ДокОснование.КурсВзаиморасчетов);
ЗапросПоТоварам.УстановитьПараметр("Кратность", ДокОснование.КратностьВзаиморасчетов);
ЗапросПоТоварам.УстановитьПараметр("ТекущийДокумент", ДокОснование.Ссылка);
ЗапросПоТоварам.Текст = "ВЫБРАТЬ
| ВложенныйЗапрос.НомерСтроки,
| ВложенныйЗапрос.Товар,
| ВложенныйЗапрос.Товар.НаименованиеПолное КАК ТоварНаименование,
| NULL КАК ОбъектСтроительства,
| NULL КАК ОбъектСтроительстваНаименование,
| ВложенныйЗапрос.СтранаПроисхождения,
| ВложенныйЗапрос.СтранаПроисхождения.НаименованиеПолное КАК ПредставлениеСтраны,
| ВложенныйЗапрос.НомерГТД,
| ВложенныйЗапрос.НомерГТД.Представление КАК ПредставлениеГТД,
| ВложенныйЗапрос.ЕдиницаИзмерения.Представление КАК ЕдиницаИзмерения,
| ВложенныйЗапрос.Количество,
| ВложенныйЗапрос.Цена,
| ВложенныйЗапрос.Сумма,
| ВложенныйЗапрос.СуммаНДС,
| ВложенныйЗапрос.СтавкаНДС,
| ВложенныйЗапрос.Характеристика,
| ВложенныйЗапрос.Серия
|ИЗ
| (ВЫБРАТЬ
| ТаблицаПоТоварам.НомерСтроки КАК НомерСтроки,
| ТаблицаПоТоварам.Номенклатура КАК Товар,
| ТаблицаПоТоварам.СерияНоменклатуры.СтранаПроисхождения КАК СтранаПроисхождения,
| ТаблицаПоТоварам.СерияНоменклатуры.НомерГТД КАК НомерГТД,
| ТаблицаПоТоварам.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
| СУММА(ТаблицаПоТоварам.Количество) КАК Количество,
| ТаблицаПоТоварам.Цена КАК Цена,
| ТаблицаПоТоварам.Сумма КАК Сумма,
| ТаблицаПоТоварам.СуммаНДС КАК СуммаНДС,
| ТаблицаПоТоварам.СтавкаНДС КАК СтавкаНДС,
| ТаблицаПоТоварам.ХарактеристикаНоменклатуры КАК Характеристика,
| ТаблицаПоТоварам.СерияНоменклатуры КАК Серия
| ИЗ
| Документ.КорректировкаНеотфактурованнойПоставки.Товары КАК ТаблицаПоТоварам
|
| ГДЕ
| ТаблицаПоТоварам.Ссылка = &ТекущийДокумент
|
| СГРУППИРОВАТЬ ПО
| ТаблицаПоТоварам.НомерСтроки,
| ТаблицаПоТоварам.Номенклатура,
| ТаблицаПоТоварам.ЕдиницаИзмерения,
| ТаблицаПоТоварам.СтавкаНДС,
| ТаблицаПоТоварам.Цена,
| ТаблицаПоТоварам.СерияНоменклатуры.СтранаПроисхождения,
| ТаблицаПоТоварам.СерияНоменклатуры.НомерГТД,
| ТаблицаПоТоварам.ХарактеристикаНоменклатуры,
| ТаблицаПоТоварам.СерияНоменклатуры,
| ТаблицаПоТоварам.Сумма,
| ТаблицаПоТоварам.СуммаНДС) КАК ВложенныйЗапрос

|ОБЪЕДИНИТЬ ВСЕ

|ВЫБРАТЬ
| ТаблицаПоУслугам.НомерСтроки,
| ТаблицаПоУслугам.Номенклатура,
| ТаблицаПоУслугам.Содержание,
| NULL,
| NULL,
| ""Россия"",
| ""Россия"",
| ""--"",
| ""--"",
| ТаблицаПоУслугам.Номенклатура.ЕдиницаХраненияОстатков.Представление,
| ТаблицаПоУслугам.Количество,
| ТаблицаПоУслугам.Цена,
| ТаблицаПоУслугам.Сумма,
| ТаблицаПоУслугам.СуммаНДС,
| ТаблицаПоУслугам.СтавкаНДС,
| NULL,
| NULL
|ИЗ
| Документ.КорректировкаНеотфактурованнойПоставки.Услуги КАК ТаблицаПоУслугам

|ГДЕ
| ТаблицаПоУслугам.Ссылка = &ТекущийДокумент

|ОБЪЕДИНИТЬ ВСЕ

|ВЫБРАТЬ
| ТаблицаПоОборудованию.НомерСтроки,
| ТаблицаПоОборудованию.Номенклатура,
| ТаблицаПоОборудованию.Номенклатура.НаименованиеПолное,
| NULL,
| NULL,
| ТаблицаПоОборудованию.СерияНоменклатуры.СтранаПроисхождения,
| ТаблицаПоОборудованию.СерияНоменклатуры.СтранаПроисхождения.НаименованиеПолное,
| ТаблицаПоОборудованию.СерияНоменклатуры.НомерГТД,
| ТаблицаПоОборудованию.СерияНоменклатуры.НомерГТД.Представление,
| ТаблицаПоОборудованию.ЕдиницаИзмерения.Представление,
| ТаблицаПоОборудованию.Количество,
| ТаблицаПоОборудованию.Цена,
| ТаблицаПоОборудованию.Сумма,
| ТаблицаПоОборудованию.СуммаНДС,
| ТаблицаПоОборудованию.СтавкаНДС,
| ТаблицаПоОборудованию.ХарактеристикаНоменклатуры,
| ТаблицаПоОборудованию.СерияНоменклатуры
|ИЗ
| Документ.КорректировкаНеотфактурованнойПоставки.Оборудование КАК ТаблицаПоОборудованию

|ГДЕ
| ТаблицаПоОборудованию.Ссылка = &ТекущийДокумент

|ОБЪЕДИНИТЬ ВСЕ

|ВЫБРАТЬ
| ТаблицаПоОбъектамСтроительства.НомерСтроки,
| NULL,
| NULL,
| ТаблицаПоОбъектамСтроительства.ОбъектСтроительства,
| ТаблицаПоОбъектамСтроительства.ОбъектСтроительства КАК ОбъектСтроительстваНаименование,
| ""Россия"",
| ""Россия"",
| ""--"",
| ""--"",
| ""--"",
| 0,
| ТаблицаПоОбъектамСтроительства.Сумма,
| ТаблицаПоОбъектамСтроительства.Сумма,
| ТаблицаПоОбъектамСтроительства.СуммаНДС,
| ТаблицаПоОбъектамСтроительства.СтавкаНДС,
| NULL,
| NULL
|ИЗ
| Документ.КорректировкаНеотфактурованнойПоставки.ОбъектыСтроительства КАК ТаблицаПоОбъектамСтроительства

|ГДЕ
| ТаблицаПоОбъектамСтроительства.Ссылка = &ТекущийДокумент
|";

Шапка = Запрос.Выполнить().Выбрать();
ВыборкаСтрокТовары = ЗапросПоТоварам.Выполнить().Выбрать();

Шапка.Следующий();
ДанныеДляПечати = Новый Структура();
ДанныеДляПечати.Вставить("Организация", Шапка.Организация);
ДанныеДляПечати.Вставить("Номер", Ссылка.НомерВходящегоДокумента);
ДанныеДляПечати.Вставить("Дата", Ссылка.ДатаВходящегоДокумента);
ДанныеДляПечати.Вставить("Поставщик", Шапка.Поставщик);
ДанныеДляПечати.Вставить("Грузоотправитель", Шапка.Грузоотправитель);
ДанныеДляПечати.Вставить("Подразделение", Шапка.Подразделение);
ДанныеДляПечати.Вставить("Покупатель", Шапка.Покупатель);
ДанныеДляПечати.Вставить("Грузополучатель", Шапка.Грузополучатель);
ДанныеДляПечати.Вставить("Сумма", Шапка.Сумма);
ДанныеДляПечати.Вставить("Валюта", Шапка.Валюта);
ДанныеДляПечати.Вставить("УчитыватьНДС", Шапка.УчитыватьНДС);
ДанныеДляПечати.Вставить("СуммаВключаетНДС", Шапка.СуммаВключаетНДС);
ДанныеДляПечати.Вставить("ФИОРуководителя", );
ДанныеДляПечати.Вставить("ФИОГлавногоБухгалтера", );

Товары = ИнициализацияТаблицыСтрок();

Пока ВыборкаСтрокТовары.Следующий() = 1 Цикл

Строчка = Товары.Добавить();
Если ЗначениеЗаполнено(ВыборкаСтрокТовары.Товар) Тогда
Строчка.Товар = ВыборкаСтрокТовары.Товар;
Строчка.ТоварНаименование = ВыборкаСтрокТовары.ТоварНаименование + ФормированиеПечатныхФормСервер.ПредставлениеСерий(ВыборкаСтрокТовары);
ИначеЕсли ЗначениеЗаполнено(ВыборкаСтрокТовары.ОбъектСтроительства) Тогда
Строчка.Товар = ВыборкаСтрокТовары.ОбъектСтроительства;
Строчка.ТоварНаименование = ВыборкаСтрокТовары.ОбъектСтроительстваНаименование;
КонецЕсли;
Строчка.СтранаПроисхождения = ВыборкаСтрокТовары.СтранаПроисхождения;
Строчка.ПредставлениеСтраны = ?(НЕ ЗначениеЗаполнено(ВыборкаСтрокТовары.ПредставлениеСтраны), ВыборкаСтрокТовары.СтранаПроисхождения, ВыборкаСтрокТовары.ПредставлениеСтраны);
Строчка.НомерГТД = ВыборкаСтрокТовары.НомерГТД;
Строчка.ПредставлениеГТД = ВыборкаСтрокТовары.ПредставлениеГТД;
Строчка.Количество = ВыборкаСтрокТовары.Количество;
Строчка.ЕдиницаИзмерения = ВыборкаСтрокТовары.ЕдиницаИзмерения;
Строчка.Цена = ВыборкаСтрокТовары.Цена;
Строчка.СтавкаНДС = ВыборкаСтрокТовары.СтавкаНДС;
Строчка.СуммаНДС = ВыборкаСтрокТовары.СуммаНДС;
Строчка.Сумма = ВыборкаСтрокТовары.Сумма;

КонецЦикла;

ДанныеДляПечати.Вставить("ТабличнаяЧасть", Товары);

Возврат ДанныеДляПечати;

КонецФункции // СобратьДанныеПоПоступлениюТоваров()




2)В открывшемся модуле найти функцию "СобратьДанныеДляПечати". В ней, после строки "ЭкземплярДанныхДляПечати = СобратьДанныеПоПоступлениюТоваров(СтрДокОснования.ДокументОснование, Ссылка);" вставить код
//-- 01.08.2007 ЭРТИ

ИначеЕсли ТипОснования = Тип("ДокументСсылка.АктОбУслугахЗаказчика") Тогда

ДанныеДляПечати = СобратьДанныеПоАктуОбУслугахЗаказчика(СтрДокОснования.ДокументОснование, Ссылка);

ИначеЕсли ТипОснования = Тип("ДокументСсылка.СправкаОСубподрядныхРаботах") Тогда

ЭкземплярДанныхДляПечати = СобратьДанныеСправкамОСубподрядныхРаботах(СтрДокОснования.ДокументОснование, Ссылка)

ИначеЕсли ТипОснования = Тип("ДокументСсылка.ПоступлениеДенежныхДокументов") Тогда

ЭкземплярДанныхДляПечати = СобратьДанныеПоступлениеДенежныхДокументов(СтрДокОснования.ДокументОснование, Ссылка)

ИначеЕсли ТипОснования = Тип("ДокументСсылка.КорректировкаНеотфактурованнойПоставки") Тогда

ЭкземплярДанныхДляПечати = СобратьДанныеПоКорректировкамНеотфактурованнойПоставки(СтрДокОснования.ДокументОснование, Ссылка)

//--


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ 1 сообщение ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
POWERED_BY
Русская поддержка phpBB